bugtex4ht - Bugs: bug #396, Issue with nested tables, array...

 
 
Show feedback again

You are not allowed to post comments on this tracker with your current authentification level.

bug #396: Issue with nested tables, array package and ooffice output

Submitted by:  Michal Hoftich <michal_h21>
Submitted on:  Fri 15 Jun 2018 03:51:52 PM EEST  
 
Category: NonePriority: 5 - Normal
Severity: 5 - NormalStatus: None
Privacy: PublicAssigned to: None
Open/Closed: Open

Fri 15 Jun 2018 03:51:52 PM EEST, original submission:

I've found really strange issue with the behavior of nested tables when the array package is loaded and the ODT output is active. More details are here:

https://tex.stackexchange.com/a/436560/2891

It seems that a \special{t4ht@[} instruction is missing somewhere, but I couldn't find where. Workaround is presented in my answer, but I think we should dig deeper and find the real issue. I must admit that I don't understand at all why the \special commands are used in that context at all, there are no comments in the sources.

The other issue is that nested tables are inserted in paragraphs and this are not shown at all. I think this can be fixed only using post-processing, proposed filter for make4ht is included in my answer.

Michal Hoftich <michal_h21>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by michal_h21 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    No Changes Have Been Made to This Item
    Show feedback again

    Back to the top


    Powered by Savane 3.1-cleanup+gray